CAM Assist run failure

Incident Report for CloudNC

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 10:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2026 - 10:29 UTC

Update

The issue has been traced to a failure with a third-party provider that our service depends on. We have contacted them and are waiting for them to resolve the issue.
Posted Jun 22, 2026 - 08:51 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 22, 2026 - 08:29 UTC

Update

We are continuing to investigate this issue.
Posted Jun 22, 2026 - 08:21 UTC

Investigating

We are currently investigating
Posted Jun 22, 2026 - 08:18 UTC
This incident affected: Product services (CAM Assist 2.0 - Mastercam - AWS Commercial EU, CAM Assist 2.0 - NX - AWS Commercial EU, CAM Assist 2.0 - GibbsCAM - AWS Commercial EU, CAM Assist 2.0 - Mastercam - GovCloud US West, CAM Assist 2.0 - NX - GovCloud US West, CAM Assist 2.0 - Fusion - AWS Commercial).